Вступить в клуб →
лёгкаявопросNginx, PHP-FPM, Docker и эксплуатация

После деплоя сайт отвечает 502 Bad Gateway на все запросы

Nginx работает, статические файлы отдаются, а все PHP-страницы возвращают 502 Bad Gateway. В журнале ошибок Nginx: connect() to unix:/run/php/php8.2-fpm.sock failed (2: No such file or directory).

Где искать причину?

  • PHP-FPM не запущен или слушает другой сокет
  • В PHP-коде синтаксическая ошибка
  • Закончилось место в базе данных
  • Nginx не поддерживает PHP 8.2

🔒 Проверка ответа — для участников клуба

  • Проверка ответа
  • Подсказка, если застряли
  • Разбор с объяснением, почему так
  • Прогресс по всем задачам и виртуальные собеседования
Зарегистрироваться →

Регистрация занимает минуту

Другие задачи раздела